Amazing Picture Warping Software

Morpheus Photo Warper - Help

  1. Basics
  2. Beginner Mode Menus
  3. Layout Wizard
  4. Toolbars
  5. Pictures
  6. Dots
  7. Playing and Viewing
  8. Uploading to Websites
  9. Emailing
  10. Zooming
  11. Timeline Options
  1. Morph Options
  2. Lines
  3. Customize Dots/Lines
  4. Rendering to a File
  5. Copy and Paste
  6. Windows and Panes
  7. Preview Window
  8. Timeline Window
  9. Key Frames
  10. Shortcuts
  11. Additional Help
[show all] [hide all]

*1. Basics

The basic concept is to create a warp starting with one normal picture and distorting it, then create a movie file of your animation.

Start by using the first option on the wizard to create a new layout. The wizard will guide you through picture loading, and then give you more detailed steps to help you get started on your warp.

Place Dots - Click on the "Add Dots" tool, then click anywhere on the first picture to add a dot. To create the best warp, try to place dots on and around all key features of the picture. As an example, when warping images of faces, key features are the eyes, nose, and mouth. Remember that the more dots you place, the smoother your end result will be.

Adjust Dots - For every dot you place on the picture, a corresponding dot, or "partner" dot, will appear on the ending picture. You will only need to adjust the placement of each partner dot so that the key features warp just the way you'd like them to. To move the dots around, first click on the "Move Dots" tool, then click on any dot in either picture. Notice that the dot and its partner will both be glowing and blinking. Click on a dot and hold the mouse button down to drag the dot to a new location. Release the mouse button when the dot is at the desired location. Notice that the ending picture will be updated to show the final still frame of your warp whenever you move a dot around on either picture.

Viewing Your Warp - Once you have completed placing dots on your pictures, you can preview your warp in the "Preview" window by pressing the "Play" button. Alternatively, you can email your warp using the "Email your morph to a friend" option under the Share menu. You can also select "Render Timeline" from the File menu and you'll be able to export your warp in various movie formats for display on the Internet or Email.

For a complete detailed walkthrough of creating a basic warp, please see the tutorial.

Important tip about this help page: Many images are just thumbnails. When you move your mouse over these thumbnails and see the Enlarge arrow, simply click the picture to display the full size image. Click the full size image to shrink it back to the thumbnail in order to read the text underneath it.


*2. Beginner Mode Menus

When this box is checked in the layout wizard, many advanced options will be hidden. None of the hidden options are needed to get started creating basic warps. If you are just learning to use Morpheus Photo Warper, it is recommended that you leave Beginner Mode Menus checked in order to familiarize yourself with the basic options and make it easier to get started having fun.

Morpheus Photo Warper is a powerful program which can create even more amazing warps with the additional and more advanced options. If you want to fully explore all of the capabilities of Morpheus Photo Warper, uncheck Beginner Mode Menus and the rest of the menu items will appear. This option can also be set in the program's preferences under Edit / Preferences.


*3. Layout Wizard

To quickly get started using Morpheus Photo Warper, use the Layout Wizard. The wizard will guide you through the creation of a new layout, or it will let you load a previous layout or a sample layout. By default, the Layout Wizard will appear each time you start Morpheus Photo Warper, unless you disable it. You can re-run the wizard at any time by selecting Layout Wizard from the File menu.

Typically when creating a new warp, you will select the first option, and then click Next.

On the second page of the wizard, you should load your picture for your warp by clicking on the Load Picture button above the preview box. After you see the pictures that you want to use in the preview box, click the Next button.

The final page of the wizard provides you with some information showing you how to add and adjust dots, and then how to view your warp. You can press the Finish button and this information will still be available in a window off to the side.


*4. Toolbars

At the top of the main window, you will see two toolbars. The first toolbar is the Standard toolbar which contains an assortment of buttons to make some common tasks easier. The first section of the toolbar has buttons to create a new layout, open an existing layout, save your layout for future editing, and render your work to a file for viewing outside of Morpheus Photo Warper. The second section of the toolbar contains buttons for undo, redo, and cut, copy, and paste. Undo and redo allow you to undo almost any operation in Morpheus Photo Warper and cut, copy, and paste allow you to manipulate the dots or lines in the picture windows. Near the end of the toolbar you will find a button to load different pictures into any picture window, a dropdown box which allows you to zoom in and out of the pictures, and a help button which can be used to display any of the various help files right inside the program.

If you have unchecked the beginner mode menus option, you will see a few extra options on the Standard toolbar. First, there are options to change the color, opacity, style, and size of any dots or lines you have selected. Also, there are toggle buttons to hide or show all of the dots, lines, and triangle lines in the picture windows.

The large toolbar under the Standard toolbar is the Tools toolbar. This toolbar contains the tools which you will use the majority of the time you are creating your warp. With the Zoom tool, you can click to zoom in and right-click to zoom out. With the Pan tool, you can click and drag to view different portions of the picture when you have zoomed in. The Move Dots tool allows you to click and drag individual dots to move them around. The Select Dots tool allows you to drag a box around multiple dots, then click and drag any of those dots to move the entire group around all at once. Finally, the Add Dots tool will place a new dot on the pictures every time you click the mouse.

In normal mode, you will also have line tools which operate very similar to the dot tools. Connect Dots will allow you to add a new line by connecting any two existing dots, and will not allow any new dots to be placed. Draw Free Line will place a new line to or from an existing dot, or at any other point on the picture, where a new dot will be placed on either end of the line if needed.

There are two toolbars in the Preview window. The first toolbar contains familiar play and stop buttons used to preview your morph right inside of Morpheus Photo Warper. The buttons on each side of the track bar can be used to step forward or backward one frame at a time, and the track bar in the middle can be used to view any single frame in your warp by dragging it to the frame you want to view. The second toolbar has two buttons which let you preview in proof mode or in draft mode. Proof mode shows you what your warp will look like in the actual size and detail it will be if you render it to a file or email it. Draft mode allows you to fill the Preview window and to see your warp more quickly. There is also a display which shows you what frame number you are viewing in your animation, the time of that frame, and the total time of the entire animation.

In normal mode, you can also toggle some preview options while in draft mode. First is the stretch button, which lets you stretch the warp to fill the entire Preview window, or show it in its actual size. The next three buttons allow you to see the dots, lines, or triangles in the Preview window.

The Timeline window (which is not available in beginner mode) has one toolbar. With the first button, you can add a new warp to your timeline. Preview All Frames allows you to see a thumbnail of every frame of your warp in the Timeline window. Show Key Frames will display thumbnails of any key frames in the timeline. Key frames can exist on the exact same spot as a normal frame, or they can occur at a time location in between two normal frames. You can use Make Key Frame to turn any picture or other frame into a key frame for more control over your warp. Delete Key Frame will delete a key frame and all of the dot locations set in that key frame.


*5. Pictures

The easiest way to load pictures is to use the Layout Wizard, which will assist you in getting started with a new layout and new pictures. If you want to load a different picture, or are past the wizard, there are many other ways you can add pictures to your layout. The Load Picture button allows you to load a picture into the currently active picture window, and you can also drag picture files into the picture windows from Windows Explorer. If you are using normal mode and have the Timeline window showing, you can also drag pictures into the picture boxes in the timeline. If you drag a picture to the empty area of the Timeline window, a new warp will be appended automatically and the picture will be added to that. You can also drag multiple pictures at once to the Timeline window to load pictures for multiple warps at once.

Be sure to keep your pictures as you are working on your warp until the final warp is rendered, because only the location of the pictures on your computer is saved in your layout when you quit Morpheus Photo Warper. If you delete or move the pictures from your computer and later try to load the layout, Morpheus Photo Warper will be unable to locate the pictures. It will then prompt you to find them in order to properly see the warp again.

Transparent images and images with an alpha channel can be used if you check the "Morph the alpha channel" option in the Timeline Options window. Images such as transparent GIFs and 32bit PNGs can be animated and will use the background color from the Morph Options window in conjunction with the "Transparent threshold" to determine how the warp turns out.


*6. Dots

Each dot is really a pair of two dots; one on each picture. The opposite dot is referred to as a partner dot. Each dot pair will start out at the location on the starting picture, and move through the warp to its location given on the ending picture. For example, if you where warping a picture of a person, and wanted to make the arm look skinier, you should make sure that the partner dots to the dots you place around the arm on the starting picture, are in similar spots on the ending picture, but slightly more inward.

The more dots you place on the pictures, the smoother your end results will be. Use the Add Dots tool, then click anywhere on the picture to add a new dot. You can also hold Alt and click when using the other dot tools to quickly add a dot without switching to the Add Dot tool.

Move the dots on the pictures by clicking and dragging the dots while using the Move Dots tool. Notice when you hover over a normal dot () that it will become highlighted with color () and that dot's partner dot will become highlighted in black and white (). When you click on a dot to select it for moving, it will also blink (), as will its partner dot (). If you click on the picture, but not on a dot, the Move Dots tool will act like the Pan tool for moving around the picture when zoomed in.

There are many combinations of keys which can be used to move dots more precisely. Shift+click will move dots only in a straight vertical or horizontal line, while Ctrl+click will select a dot without allowing any movement. When you have a dot selected, you can use the arrow keys to move the dot one pixel at a time. Hold Shift while using the arrow keys to move 10 pixels at once. Hold Ctrl and use the arrows to change which dot is currently selected for movement. Press delete to remove that dot and its partner dot from the pictures. Also, if you right-click on a dot, there is a menu with some common toolbar items on it.

To move multiple dots at once, use the Select Dots tool, then click on the picture and drag a box around the dots you want to move. Next, click on any of the selected dots to move them all around together. To add dots to your existing selection, Shift+click directly on a dot, or Shift+click on the picture and drag a box around some more dots. To remove dots from your selection, use Ctrl instead of Shift.

With the Select Dots tool, the arrow keys work opposite to how they work with the Move Dots tool. Pressing the arrow keys will move around the "cursor" on the dots, which may or may not be part of your selection. Hold Ctrl and use to arrows to move the dots which are currently selected. The spacebar will toggle the cursor dot in and out of the dots selected for movement.


*7. Playing and Viewing

There are several different ways which you can see your warp:

  • The Preview window
  • The Timeline window
  • Uploading your warp to websites using the built-in upload feature
  • Emailing your warp using the built-in share feature
  • Rendering your warp to a file

The Preview window

The Preview window displays your warp right inside of Morpheus Photo Warper. The play and stop buttons can be used to view your warp at any time.

The Timeline window

The Timeline window can display a thumbnail of each frame in your warp if you select the Preview All Frames option.

Uploading your warp to websites using the built-in upload feature

The "Upload your morph to a website" option under the Share menu has a helpful wizard which can upload your warp directly to Morpheus Galleries, YouTube, or Photobucket. This allows for easy posting to blogs such as MySpace, Facebook, Friendster, and more.

Emailing your warp using the built-in share feature

The "Email your morph to a friend" option under the Share menu has a helpful wizard to assist you in sending an email with your warp attached.

Rendering your warp to a file

The Render Timeline option under the File menu lets you export your warp in various movie formats. It is important to note that saving your layout with the Save option under the File menu is not the same as rendering. Your layout is your work and can be used to modify your warp in Morpheus Photo Warper in the future. On the other hand, rendering creates a file which can be displayed in other programs, but cannot be edited in Morpheus Photo Warper.

More details about each of the ways to see your warp can be found in each respective help section.


*8. Uploading to Websites

Using the built-in upload wizard, you can send your warps directly to a webpage from right inside of Morpheus Photo Warper. You can upload directly to Morpheus Galleries, YouTube, or Photobucket.

Morpheus Galleries supports anonymous uploading so you don't even need to create an account anywhere, as well as buttons on the webpage created for your warps to quickly post your warp onto your favorite blog such as MySpace or Facebook.

The upload wizard can also save your username and password for each website so that you can quickly upload multiple warps each time. Usernames and passwords are optional for Morpheus Galleries, but are required for YouTube and Photobucket. Click the link at he bottom of the wizard if you wish to create an account at one of these sites.

On the second page of the wizard, you will select the type of file you want to create and upload to the website. Different websites support different formats, and some formats produce better results than others, depending on the websites.

You can also enter a short title for the warp on this page, which will be included with your upload.

Your warp must be rendered before it can be uploaded. Once you click Next on the second page of the wizard, the rendering process will begin automatically. When it is finished, you will see the third page of the wizard.

On the third page of the wizard, all you need to do is press the Upload Morph button when you are ready. Different websites may have different maximum file sizes, so the general recommendation is to keep your file no more than 2,000,000 bytes to ensure that it is not rejected after you upload it. If your warp is too large, you must decrease the size in the Timeline Options window or decrease the number of frames in the Morph Options window. If you are trying to send as an Animated GIF, try Flash SWF instead. If you are sending a compressed movie file, try a different codec or higher compression settings.

The bottom portion of the wizard lets you estimate how long it will take to upload your email. Larger file sizes will take longer to send, but having a faster upload speed on your internet connection will make the upload faster. It is important to know that typical residential Internet connections have much faster download speeds than they have upload speeds, by a factor of ten to twenty at times. If you do not know how fast your upload speed is, you can guess and pick different options as you watch the Elapsed time display when you upload your warp.

On the last page of the wizard, there are several different links to the webpage which is now hosting your warp. It is important to remember that some webpages, particularly YouTube, will not display your upload until it has been processed, which can take 30 minutes or more at times. The links shown on this page will work when YouTube makes your upload live, but may not work right away. You can always log into your YouTube account to verify your upload is there though. Morpheus Galleries uploads are always ready to be displayed instantly when your upload is complete.

The hyperlink at the top is a link which you can click to view the webpage of your upload directly, while the four boxes below are formatted for easy copy and paste with various other types of websites or instant messages. Simply click in the boxes to copy the entire contents to the clipboard.


*9. Emailing

The easiest way to email your warp is to use the wizard from right inside Morpheus Photo Warper. Select "Email your morph to a friend" from the Share menu. On the first page, you enter your email address and the email address(es) of the friend(s) to whom you wish to send your warp.

To send to multiple friends at once, simply separate the email addresses with a comma or semicolon like this:; If you've used the Send Morph Wizard before, your email addresses and the friends you've shared with will be remembered. You can select a previous friend's email address from the dropdown box if you wish.

Once you have entered or selected valid email addresses, the Next button should become clickable. If the Next button is still greyed out, that means you have entered an invalid email address into one of the boxes, and you must correct it before continuing.

On the second page of the wizard, you will need to choose what type of file you want to email. The default (Flash SWF) is best in most circumstances because it will upload the fastest and it will be the highest quality. Animated GIF files can typically be viewed from inside of common email programs instead of being sent as an attachment, but the nature of GIF files makes them a lower quality choice, so your warp may not look as good.

Your warp must be rendered before it can be emailed. Once you click Next on the second page of the wizard, the rendering process will begin automatically. When it is finished, you will see the final page of the wizard.

On the last page of the wizard, all you need to do is press the Send Morph button when you are ready. There is a maximum file size of 2,000,000 bytes, and any files larger than that will be rejected. If your warp is too large, you must decrease the size in the Timeline Options window or decrease the number of frames in the Morph Options window. If you are trying to send as an Animated GIF, try Flash SWF instead.

The bottom portion of the wizard lets you estimate how long it will take to send your email. Larger file sizes will take longer to send, but having a faster upload speed on your internet connection will make the email send faster. It is important to know that typical residential Internet connections have much faster download speeds than they have upload speeds, by a factor of ten to twenty at times. If you do not know how fast your upload speed is, you can guess and pick different options as you watch the Elapsed time display when you send your email.


*10. Zooming

Zooming in allows fine-tuning of dots for detailed warps and zooming out allows working with large pictures on a smaller desktop size. When using the zoom tool, each click in the picture window will double the zoom, and each right-click will cut the zoom in half.

While using any tool at all, you can select a zoom value from the zoom dropdown on the toolbar, or just type in any zoom value you wish. "Fit in Window" will automatically pick the largest zoom value possible without causing the need for scrollbars to appear.

There are several other shortcuts for zooming which you can use at any time. Scrolling your mouse wheel up or pressing the plus key will zoom in by a factor of 1.1 with each press, and scrolling down or pressing the minus key will zoom out by the same factor. The shortcut Ctrl+1 will zoom instantly to 100%, and Ctrl+W will act as if "Fit in Window" was selected.


*11. Timeline Options

The Timeline Options window can be found by selecting Options from the Timeline menu or by pressing Ctrl+I. The options here control your entire warp across the entire timeline. More options, which can vary from warp to warp, can be found in the Morph Options window.


The size of the timeline is the size (in pixels) that your final warp will be once you render it to a file. By default, the size is automatically set based on the size of the pictures that you load. The Timeline menu contains a submenu called Size where you can either select automatic sizing or set your timeline to some common sizes.


Normally when you render the timeline to a file, you are prompted for a file name and which file type to create. Here you can set a specific file format to be used every time by selecting it from the dropdown. If you select Compressed AVI, then you can also select a specific codec to compress with each time instead of being prompted for it every time you render the timeline. All DirectShow compatible codecs will show up as available to use, but that does not mean each codec will work. Some codecs may be decompression-only, and others may have requirements such as specific timeline sizes or sizes that are intervals of 4, 8, or 16 pixels.

If a specific file format is selected, you can additionally choose to always render to the same file name by checking the "Always render to the same file" box, then by clicking Browse and entering a file name.

When "Generate companion html file" is selected, it will create an additional file when you render the timeline with the same name as the main file, but with an html extension. The html companion file will contain a sample web page which loads the correct plugin needed to display the warp. This is particularly useful for the Flash SWF format which is file type that can normally only be viewed on a web page with the Flash plugin.

If "Open morph file after rendering" is checked, then the newly created file will open as if you clicked on it automatically every time you render the timeline.


The "Morph the alpha channel" option will cause Morpheus Photo Warper to calculate a full 32bit image for each frame rendered instead of the normal 24bit image. This allows transparency information to be preserved in the warp or at least to control when pixels show through to the background color, depending on if the file format rendered to supports any type of transparency.

The Transparent threshold value controls the minimum value the alpha channel for a pixel can be without making that pixel entirely transparent and become the background color. For example, a value of 0 will preserve a perfect 32bit image with all calculated translucency, suitable for Flash SWF or PNG files. A value of 128 will make all rendered pixels with an alpha value from 0 to 127 become entirely transparent, and alpha values 128 to 255 will be normal, which is suitable for Animated GIF files.

Not all file formats support transparency.
  • Compressed AVI may or may not support full alpha channels, depending on the codec. Some codecs may simply discard the alpha channel and compress the image stream as if it were 24bit, while some codecs may allow the alpha channel to be preserved.
  • Uncompressed AVI files will be written with the alpha channel information, but it is up to the software processing the AVI to later do anything with the information, and many programs simply discard it.
  • Flash SWF fully supports 32bit images with alpha channels.
  • Animated GIF supports a single transparent palette entry and will use the transparent threshold to calculate which pixels become transparent.
  • PNG, TIFF, and Targa files fully support 32bit images with alpha channels.
  • Bitmap files support 32bit images, but not many viewers recognize them as being transparent.
  • JPEG and XPM files do not support any transparency at all.


The Quality option controls the compression of Flash SWF and JPEG files. Both of these file formats are lossy, which means that they do not store a perfect representation of the picture being saved. There is a tradeoff between file size and image quality. The lower you set the Quality, the smaller the file size, but the worse the image will look. The higher you set the quality, the better the image will look, but it may take longer to download or email because of the larger file size.

The "Different quality setting for ends of each morph" option lets you pick a different quality setting for the still frame(s) on each end of each warp in your timeline. This lets you use a higher quality image for the still before and after frames, while making the file size smaller by using a lower quality setting for the animated frames in the middle.

The Render speed should normally be left at 1, but if you have a very large warp and need to render it to a file quickly, you can set the speed higher. Each higher render speed setting will calculate fewer and fewer pixels, resulting in a blocky picture, but noticeably speeding up the time it takes to render the timeline.


None of the options under Playback apply to any of the still image file formats (PNG, JPG, TIFF, BMP, TGA, and XPM) unless the "Generate companion html file" option is selected. In this case the generated html file will use javascript to animate the still images using the options specified here.

Frames per second is one way to control the speed of your warp. Higher frames per second will result in a smoother warp but one which will last for a shorter duration, while less frames per second will result in a more choppy warp that lasts for a longer time.

Render direction allows you to have the timeline play forward, backward, or both directions, which will have the animation play forward, then backward back to the beginning.

Loop morph lets you decide if your animation should loop forever, play through once then stop on the last frame, or play through a certain number of times before stopping. Some file formats, such as AVIs, do not support any loop option to be specified in the file itself, so this option will only apply if you also select "Generate companion html file" where the plugin used to play the AVI can specify the loop value. Additionally, if you want an AVI file to play through only once, it may not stop on the final frame because some AVI players will "rewind" the movie back to the starting frame for you. You can only change this behavior in the program you are viewing the movie with.

The "Wait for morph to load before playing" option only applies to Flash SWF and still image file formats. For Flash SWF, a small progress bar will be displayed as part of the SWF, and the warp will remain on the first frame until the entire file loads, at which point it will start playing. For still image files, the html file will produce a similar effect using the javascript generated.


*12. Morph Options

The Morph Options window can be found by selecting Options from the Morph menu, or by pressing Ctrl+O. The options here control only the specific warp for which they are set, and each warp can have different options set for it here. More options which control the entire timeline can be found in the Timeline Options window.

Frames and Time

Here you can set the length of your warp as well as the amount of time to pause on the starting and ending frames before and after the animation plays. The three boxes on the right are linked to the three boxes on the left, and changing one side will update the other side based on the frames per second value set in the Timeline Options window.

The number of frames in your warp affects the speed at which the animation plays. More frames will result in a longer animation which transitions between pictures more slowly, but more frames will also result in a larger file size. Less frames will produce a smaller file size, which can be downloaded or emailed faster, but the animation will also play through more quickly. Also see the frames per second option in the Timeline Options for another way to control the speed of your warp.

What to Render

If you disable rendering the starting picture but leave the ending picture on the warp will function in the opposite direction, starting out distorted and ending up at the regular picture.

If you want, you can have the dots, lines, and triangle lines all rendered on top of your movie by selecting any of the last three checkboxes.

Rendering Options

The Background color is the color that will be used if no picture is loaded, if the picture is not checked to be rendered, if "Remove triangles touching the corners" is checked, or for any places where the pixels become transparent when the "Morph the alpha channel" option in the Timeline Options is used.

Smooth pixels will create a much nicer looking result by interpolating rendered pixel values instead of just estimating to the nearest pixel. If this option is unchecked, then the results may render significantly faster, but it may look more blocky in some places.

The "Remove triangles touching the corners" option will actually cause the 4 implied dots located at the corners of each picture to no longer be used for creating the triangles. This means that you must place your own dots around the areas you want to show up, and any area not covered by a triangle made up entirely of the dots you placed will show through to the background color.


*13. Lines

Lines allow for more fine tuning of the creation of the triangles that actually control which portions of the starting picture turn into which portions of the ending picture. If you enable the Show Triangles option , then you can see all of the automatically generated triangle lines, creating the optimal triangle configuration based on the locations of all currently placed dots.

Sometimes you may want to move dots in certain positions that cause the triangles to overlap, which can create funny edges in your warp. You can see in the example here how the yellow dot crosses over the triangle line which connects the black and green dots. Normally, you would want to avoid doing this.

The solution to this problem is to define some lines of your own. In this case, if you add a line connecting the yellow and red dots, then the line which connected the black and green dots will no longer be generated, and the dots can move to the same position in the ending picture without causing overlapping triangles.

The Move Lines tool functions just like the Move Dots tool, except it works on lines. Lines will become highlighted and blink with color, and their partner lines will do the same in black and white. The same arrow key combinations used to move dots also works to move lines. The Delete key will also delete a selected line.

The Select Lines tool functions just like the Select Dots tool, except it works on lines. When dragging a selection box to select lines, only a piece of the line must be inside the box to be selected. You do not need to drag the box around the entire length of the line.

Connect Dots will allow a new line to be placed, without creating any new dots in the process. You can either click on a dot, hold the button down, and drag a line to any other existing dot, or you can click on a dot and let go, then click on another dot. With this tool, you do not need to drag the mouse all the way to the second dot or click on the second dot. A dotted line will be shown from the first dot to the dot nearest the current mouse pointer location as you move the mouse around, showing you exactly where the new line will be created. Morpheus Photo Warper will not allow two lines to be connected to the same two dots, and attempting to do so will produce no new line.

Draw Free Line operates similar to Connect Dots, except that you can optionally create one or two new dots in the process of adding a line. Either end of the line you create can be on an existing dot or in any empty place on the picture, where a new dot will be created. If you hold Shift with the first click, then only a horizontal or vertical line will be created. When using the Move Lines or Select Lines tools, Alt+click will add a line, just like it would add a dot when using the dot tools. Though this will require a second click (or a long drag from the first click) for the other end of the line. Also, Alt+Shift+click will add only a straight horizontal or vertical line.


*14. Customize Dots/Lines

Dots and lines can be displayed in a variety of different color schemes, styles, and sizes. By default, dots are set to cycle through a set of 8 colors in a medium sized square shape. Each warp in your timeline can be given a different look for the dot's default look in that warp.

The color scheme allows you to have dots be automatically assigned a color from a set palette, have all dots be a single solid color picked from the color button on the next line, or have the dots invert the picture behind them. Opacity can be changed to give the dots varying degrees of translucency. There are many different styles to choose from other than a square, such as circles, crosshairs, or even just outlines of shapes. Finally, you can adjust the size of the dots. Larger dots are easier to click on and smaller dots are easier to place more precisely.

Lines can be displayed in a variety of different ways just like dots, except there is no shape selection. By default, all lines are a solid color.

Triangles can also be customized with all the same choices as lines. All lines are also triangle lines, but when you are viewing both lines and triangle lines in your pictures, the settings for lines will be used for the lines you placed, while the settings for triangles will be used for the generated lines which cannot be moved.

In addition to being able to set a default way to display dots and lines for each warp, you can assign specific customization to dots and lines individually by using the Customize Selected Items option under the Edit menu. While the color scheme option does not apply to customizing a specific dot or line, there is an additional choice for each option called 'Automatic'. Selecting Automatic for any of the various options will result in using the default settings for that warp.

Customizing groups of dots or lines individually lets you group them to your tastes, to separate pieces of your work. For example, you could set all the dots around the eyes in a picture of a face to one color and shape, and set the dots around the mouth to a different color and shape.

These four buttons on the toolbar will also allow you to customize selected dots and lines, just like the Customize Selected Items option. You can also use the Page Up and Page Down keys to quickly cycle through eight basic colors for dots or lines. Pressing Shift+Page Up or Shift+Page Down will cycle through shapes for selected dots as well.


*15. Rendering to a File

When you are finished with your warp, you will want to render it to a file so you can view it in other programs, upload it to your webpage, or email it to a friend. Use the Render Timeline button on the toolbar to render your warp.

After you select a folder and enter a file name, make sure you select the type of file you want to render to from the "Save as type" dropdown at the bottom of the Save As window.

While your animation is rendered, you will see a progress window, showing what frame number is currently being rendered, how much time has elapsed since the rendering started, and an estimate of how much time is remaining.

It is important to note that saving your layout with the Save option does not do the same thing as rendering with the Render Timeline option .

Save Layout

Your layout is the work you have done so far in Morpheus Photo Warper. The picture(s) you have loaded, the placement of any dots and lines, and all options you have set in either of the options windows are stored in your layout file when you press the Save Layout button. Morpheus Photo Warper can only load your layout file if you want to edit your warp in the future, and not any other file type. Other programs cannot load, edit, or view the layout files created by Morpheus Photo Warper, since the layout file format is specific to Morpheus Photo Warper.

Render Timeline

Rendering the timeline creates a movie file in a standard format which many other programs can load and view. The files rendered by Morpheus Photo Warper cannot contain information about how you created the movie, such as where you placed the dots, and so you cannot load these files back into Morpheus Photo Warper for future editing of your warp.


*16. Copy and Paste

Cut, Copy, and Paste work similar to how they work in other programs, with one important difference: When you cut or copy dots or lines, what you are actually copying is the locations of those dots or lines on the picture. When you paste dots or lines, you will actually be pasting the locations of the dots or lines, in effect, moving them to new locations.

When pasting dots or lines, the result will be different depending on whether anything is currently selected or not. When nothing is selected, all of the dots or lines with corresponding information on the clipboard will be moved to their new locations. For any dot or line information on the clipboard which does not have a corresponding dot or line in the picture window, a new dot or line may be placed.

When there is something selected, those selected dots or lines will be moved using the information on the clipboard. If there is information about more dots or lines on the clipboard than there are dots or lines selected, some information from the clipboard will not be used, and only the selected dots or lines will be moved. If there are more dots and lines selected than those on the clipboard, some of the selected dots or lines will become unselected, and the ones that remain selected will be moved.

Copying dots will also copy information about any lines connected to any of the dots copied, and copying lines will also copy information about the dots on each end of every line copied. Normally cutting can be thought of as copying and deleting combined into one operation, but with Morpheus Photo Warper, copying will remember which dots or lines the locations correspond to, and cutting will not.


*17. Windows and Panes

Some of the windows in Morpheus Photo Warper are actually docking panes which can be attached to the sides of the window, or they can be floated on top of the entire program. Each Docking pane has an auto hide button and a close button in their upper right corners. The help screens are all docking panes, and the Timeline and Preview windows are also docking panes by default. The Timeline and Preview windows can each be made into normal windows like the picture windows by unchecking the Timeline Dockable or Preview Dockable options under the View menu.

Closing a pane with the close button works just like closing a normal window. You can reshow the Timeline and Preview windows by selecting those options from the View menu. Help panes can be reshown by selecting them from the Help menu.

When you press the auto hide button the docking pane will hide itself and leave behind a tab with its name on it. When you hover over the tab, the pane will pop back up on top of the window until you move your mouse away. If you click on the docking pane, it will stay visible until you click on a different window or docking pane. Press the auto hide button again to dock the pane back in a permanent position if you no longer want it to automatically hide and show itself like this.

When you have two or more panes docked in the same location, you will also see tabs for each docking pane . Only one of the panes will be visible at a time and clicking on the tabs changes which pane you see. You can also click and drag the tabs to rearrange the order however you like.

If you click and drag a docking pane's title, or click and drag the tab when more than one pane is docked at the same location, you can move the pane to another location. These buttons will help you dock a pane by allowing you to drag the mouse to either one of the four edge buttons in order to dock the pane to a particular side of the window, or to the middle button which will dock the pane with an existing pane.

Panes can be resized when they are docked by dragging the edge; similar to how normal windows can be resized. Panes that are docked and not set to auto hide will take up space that regular windows cannot use. So if you need more room for your picture windows, you can either shrink the size of the docking panes or set them to auto hide.

By default, the regular windows, such as all of the picture windows, are always maximized and shown on a tab bar. The windows can be separated into groups of tabs, and each group has left and right buttons to move through the tabs when many windows are open at once. The close button appears on the tab of any visible picture window.

The window tabs can be clicked and dragged for reordering, or they can be dragged to other groups. Drag a tab to the edges of a group to split the group in half, creating a new group.

If you do not like the tab groups, and want the windows to have the familiar minimize, maximize, and close buttons , you can select View / Window Tabs / No Window Tabs. With this option, windows can be moved and resized inside of the main Morpheus Photo Warper window. There is also the View / Window Tabs / With Regular Windows option, which will use regular windows with the minimize, maximize, and close buttons, but it will also have a tab bar showing all open windows. This hybrid option does not allow tabs to be grouped like the default option. Without tab groups, when a window is not maximized, you can use the Snap Window option under the Picture menu to snap the edges of the window around the picture space, eliminating the extra border area.

When using the View / Window Tabs / With Tab Groups mode, which is the default, Arrange Icons and Windows option for the window manager will not be available under the Window menu, because with the tab groups, all windows are always maximized. Tile Horizontally and Tile Vertically will function to set each open window into its own group, while Cascade will place all open windows into one single group. You can still select a window for focus from the Window menu, but clicking on the tabs in the tab bar has the same effect. The Snap Window option is also unavailable with tab groups.

The Windows skin can be changed by selecting a different skin from View / Skin. There are several varieties of skins to choose from, including a basic one to use the native OS style instead. The functionality of the program is not affected by the skins, although some skins may have less visual cues for hovering or dragging effects.


*18. Preview Window

The Preview window displays one frame of your warp at a time and is constantly updated as you add or move dots or lines in the picture windows to show you what the results will look like. Toggle displaying and hiding the Preview window by pressing Ctrl+P.

The Play and Stop buttons can be used to animate the Preview window by showing what the animation would look like when rendered to a file. Options such as the Frames per second, Render direction, and Loop morph options in the Timeline Options window will be obeyed when playing your animation in the Preview window. Depending on the speed of your computer, the animation may play slower than desired if frames cannot be rendered in time. Select a faster draft speed or render your animation to a file and play that file to see the actual speed. Also, when in proof mode, drawing Dots/Lines/Triangles is controlled by the respective options in the Morph Options window instead of by the buttons on the Preview toolbar.

The track bar can be used to move the display to any frame in any warp in the timeline. The buttons on each side of the track bar will move the display in the Preview window forward or backward one frame at a time. Note that all frames such as the "Frames to hold for at start" will be shown in the Preview window exactly as they would when the animation is rendered to a file. The label below the track bar shows which frame is currently being displayed out of the total number of frames in the entire timeline. It also displays the current time at which the frame being shown starts being displayed, and the total length of the entire timeline in minutes and seconds in parentheses. Please note that the last frame does not start at the time which is equal to the length of the entire timeline. In an animation, frames are displayed for a certain short duration, and thus total length is equal to the time at which the last frame stops, not starts, being displayed.

The Proof and Draft buttons change how the Preview window displays the current frame. In proof mode the rest of the buttons are disabled, and the frames are always displayed in the exact size and quality used when rendering to a file. This may mean that the preview is displayed smaller than it could be, leaving empty space around the edges, or that it is displayed with scrollbars if it does not all fit in the Preview window. In draft mode, the picture is rendered faster, depending on which draft speed is selected from the menu associated with the Draft button. The higher the draft speed, the more pixelated the Preview window will display, but the quicker the frame can be displayed.

The Stretch to Fit , Draw Dots , Draw Lines , and Draw Triangles buttons are only available in draft mode. Stretch to Fit will cause the Preview window to display the frame as large as possible without using scrollbars. Turning Stretch to Fit off will display the frame the actual size it will be rendered, leaving empty space or using scrollbars as needed. The three draw buttons will toggle showing the current position of the dots, lines, and triangles in the Preview window. These can be useful for watching how the dots move from their positions on the starting pictures to their positions on the ending pictures and understanding how the warp works.


*19. Timeline Window

The Timeline window shows thumbnails of all the pictures for each warp in your layout. You can add additional warps to the timeline by using the first button on the Timeline toolbar. To open a picture in order to place dots or lines on it, doubleclick on the thumbnail in the Timeline window. If you doubleclick on the warp buttons above the pictures, then both pictures for that warp will be opened side by side. Toggle displaying and hiding the Timeline window by pressing Ctrl+T.

The Preview All Frames button will show a thumbnail of each frame in your warp so you can quickly see the progress of your entire layout without needing to use the track bar in the Preview window. There are also several useful menus if you right-click on any of the warp, picture, or regular frame buttons in the Timeline. Doubleclicking on a regular frame thumbnail will jump to that frame in the Preview window. While the Timeline window shows the starting and ending pictures, and each of the frames in between when the Preview All Frames option is checked, it does not show a button for each extra frame where the starting or ending pictures are repeated if the "Frames to hold for" options are used in the Morph Options window.

To delete warps from the timeline, right-click on the warp button and select Delete. New warps can also be inserted before or after the selected one on the same menu.

The key frame options on the timeline are explained in their own section below.


*20. Key Frames

Key frames allow for paths to be defined for the dots to travel across during the warp, other than the default straight line from the starting location on the starting picture to the ending location on the ending picture. Key frames allow you to create more dynamic and flowing warps, instead of direct and simple transitions.

In the Timeline window, key frames can be shown or hidden by selecting the Show Key Frames button. In Morpheus Photo Warper, key frames are assigned to a certain percentage point into the warp from 0% to 100%. To quickly add a key frame to the timeline, select Preview All Frames to see a thumbnail of each frame in your warp, then select any of the frames and press the Make Key Frame button. This will create a key frame at the same location as the frame button you have selected. The starting and ending pictures can also be made into key frames and will reside at exactly 0% and 100% respectively. To remove a key frame from the timeline, select it and then press the Delete Key Frame button.

To insert a key frame at an exact point in the timeline, select Insert Key Frame from the Timeline menu. Select which warp to add the key frame too, then enter a percentage anywhere from 0.00 to 100.00, and click OK. Key frames added this way may not line up exactly on a regular frame in the Timeline window, but there are no downsides to that.

To place dots or lines on a key frame, doubleclick on the key frame button in the Timeline window. These buttons are marked with "KF:" to show the location of the key frame in the warp. If you created a key frame at 0% or 100%, doubleclicking the button will open the starting or ending picture as it normally would. To edit these key frames, use the right-click menu and select Show Key Frame instead. Another way to access the key frames is to use the [ and ] shortcut keys, which will jump one at a time between all of the key frames in one warp.

Dots and lines on key frame windows are shared between all key frames and the two pictures in the warp. Adding or deleting a dot from any picture or key frame will also add or delete the partner dot on every other key frame and both pictures. This is because the key frames are simply reference points for each dot to reach as it travels from the starting to the ending picture's position. Key frame windows are updated as you work to display what that point in the warp looks like. Moving a dot on either picture window will change what all of the key frames look like, while moving a dot on a key frame window will instantly update that key frame window to reflect the changes.

Interpolate Selected Dots is an option available under the Edit menu when you have one or more dots selected on a key frame window. This option will allow you to automatically place dots at the position they would be at, for the correct percentage point of the current key frame interpolated between two other key frames or pictures. For the "From location," you can select the Starting Picture, or any key frame which occurs before the current one. For the "To location," you can select the Ending Picture, or any key frame which occurs after the current one. For example, if you have four key frames, at 20%, 40%, 60%, and 80%, and select some dots on the 40% key frame, and select to interpolate from the 20% key frame to the 80% key frame, then all of the dots selected will move to positions weighted by 2/3 of the coordinates of the dots on the 20% key frame, and 1/3 of the dots on the 80% key frame. This is because the 40% key frame is twice as close (in percentage value) to the 20% key frame as it is to the 80% key frame.


*21. Shortcuts

Many things that can be done in Morpheus Photo Warper by using the mouse can also be done by using keyboard shortcuts or other alternative methods.

General Shortcuts
Ctrl+S Save Layout
Ctrl+R Render Timeline
Ctrl+Z Undo last operation
Ctrl+Y Redo last undone operation
Ctrl+I Timeline Options
Ctrl+P Toggle Preview window
Ctrl+T Toggle Timeline window
F1 Help
Alt+Left/Right Forward/Backward 1 frame in the Preview window
Shift+Alt+Left/Right Forward/Backward 1 warp in the Preview window
Ctrl+Alt+Left/Right Jump to first/last frame in the Preview window
Per-Picture Shortcuts
Ctrl+O Morph Options
Ctrl+1 Zoom to 100%
Ctrl+W Zoom to automatically fit in window
Mouse Wheel Up / + Zoom in
Mouse Wheel Down / - Zoom out
Enter Jump back and forth between the two picture windows
[ / ] Jump between the picture windows and key frame windows
Tool Shortcuts
P Pan
Z Zoom
D Move Dots
S Select Dots
A Add Dots
L Move Lines
E Select Lines
C Connect Dots
F Draw Free Line
Move or Select Dots or Lines Shortcuts
Ctrl+X Cut dots/lines positions
Ctrl+C Copy dots/lines positions
Ctrl+V Paste dots/lines positions
Delete Delete dots/lines
Ctrl+A Select all dots/lines
Ctrl+D / ESC Deselect all dots/lines
Ctrl+U Customize selected dots/lines
Page Up/Down Change selected dots/lines color
Shift+Page Up/Down Change selected dots style
Alt+Click Add dot or draw free line
Shift+Alt+Click Draw free straight hroizontal or vertical line
Move Dots or Lines Shortcuts
Click+Drag Dot/Line Select a single dot/line and move it
Click+Drag Picture Deselect dot/line and pan picture
Shift+Click+Drag Dot/Line Select a single dot/line and move it only in a straight horizontal or vertical line
Ctrl+Click Dot/Line Select a single dot/line without being able to move it
Arrow Keys Move dot/line by 1 pixel
Shift+Arrows Move dot/line by 10 pixels
Ctrl+Arrows Move cursor to nearest dot/line
Ctrl+Shift+Arrows Move cursor 10 dots/lines at a time
Select Dots or Lines Shortcuts
Click+Drag Picture Set a new selection by dragging a rectangle around dots/lines
Click+Drag Selected Dot/Line Move dots/lines
Click+Drag Unselected Dot/Line Select just that dot/line and move it
Shift+Click+Drag Picture Add dots/lines inside rectangle to selection
Shift+Click+Drag Dot/Line Add dot/line to selection and move entire selection
Ctrl+Click+Drag Picture Remove dots/lines inside rectangle from selection
Ctrl+Click Dot/Line Remove dot/line from selection
Arrow Keys Move cursor to nearest dot/line
Shift+Arrows Move cursor 10 dots/lines at a time
Ctrl+Arrows Move selected dots/lines by 1 pixel
Ctrl+Shift+Arrows Move selected dots/lines by 10 pixels
Spacebar Toggle the cursor dot/line in and out of the selection
Draw Free Line Shortcuts
Shift+Click Draw straight horizontal or vertical line

Also, right-click in the picture windows, on dots and lines, on any of the buttons in the Timeline window, or on any of the toolbars at the top of the main window for helpful popup menus.


*22. Additional Help

Please run through the tutorial, read the FAQ, and play around with the variety sample warps that come included with Morpheus Photo Warper.

If you have come to this point and you still have questions or if you would like to suggest a feature, feel free to visit our support forums and we will do our best to assist you in making your experience with Morpheus Photo Warper a great one.

Thank you for using Morpheus Photo Warper.